openSUSE 11.4 Adobe Air x86_64

Install the following:

sudo zypper install libasound2-32bit libgcc45-32bit libncurses5-32bit libxml2-32bit mozilla-nss-32bit mozilla-nspr-32bit gtk2-devel libxml2-devel-32bit libxml2-devel libxslt-32bit rpm-32bit rpm-devel libstdc++33-32bit libstdc++33-devel-32bit libgnome-keyring0-32bit

Grab the rpm for Adobe Air:

http://get.adobe.com/air/

Install it:

sudo zypper in adobeair.i386.rpm

Advertisements

3 thoughts on “openSUSE 11.4 Adobe Air x86_64

  1. Hi,

    I have installed all packages you listed above, but when I run “sudo zypper in adobeair.i386.rpm”, I always get below error message:

    $ sudo zypper in adobeair.i386.rpm
    Loading repository data…
    Reading installed packages…
    Resolving package dependencies…

    The following NEW package is going to be installed:
    adobeair

    1 new package to install.
    Overall download size: 19.9 MiB. After the operation, additional 44.5 MiB will be used.
    Continue? [y/n/?] (y): y
    Retrieving package adobeair-2.6.0-19170.i386 (1/1), 19.9 MiB (44.5 MiB unpacked)
    Retrieving package adobeair-2.6.0-19170.i386 (1/1), 19.9 MiB (44.5 MiB unpacked)
    Installing: adobeair-2.6.0-19170 [error]
    Installation of adobeair-2.6.0-19170 failed:
    (with –nodeps –force) Error: Subprocess failed. Error: RPM failed: warning: /var/cache/zypp/packages/_tmpRPMcache_/adobeair-2.6.0-19170.i386.rpm: Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY

    Running 32-bit AIR on 64-bit systems has not been fully tested. However, 32-bit AIR is expected to run on 64-bit systems if they have the required 32-bit libraries and packages installed.
    The following links describe how to install or update AIR 2.6 on 64-bit versions of Ubuntu 9.10, Fedora Core 12 and OpenSuse 11.2.
    Installing Adobe AIR 2.6 on 64-bit Linux visit http://kb2.adobe.com/cps/521/cpsid_52132.html
    Updating to Adobe AIR 2.6 on 64-bit Linux visit http://kb2.adobe.com/cps/521/cpsid_52132.html
    Adobe AIR could not be installed. Either gnome-keyring or Kwallet must be installed prior to installing Adobe AIR.
    error: %pre(adobeair-2.6.0-19170.i386) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping adobeair-2.6.0-19170

    Abort, retry, ignore? [a/r/i] (a): a
    Problem occured during or after installation or removal of packages:
    Installation aborted by user

    Please see the above error message for a hint.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s